技術仕様
MCPサーバーの仕様
- エンドポイントは
https://mcp-beta.calil.jp/mcp - Model Context Protocol (Version 2026-07-28準拠)
- 2025-11-25以前のバージョンのクライアントからも、これまでどおり接続できます
- Remote MCP
- Streamable HTTP(ステートレス)
- OAuth 2.1 Authorization Framework
- Proof Key for Code Exchange(RFC 7636、S256)
- OAuth Client ID Metadata Document(CIMD)
- Dynamic Client Registration (RFC 7591)
カーリルが確認したリダイレクト先URIについてホワイトリスト方式で許可しています。追加対応の希望があればご相談ください。localhostは既定で許可しています。 - OAuth 2.0 Protected Resource Metadata (RFC 9728)
- OAuth 2.0 Authorization Server Metadata (RFC 8414)、OpenID Connect Discovery 1.0
- Resource Indicators for OAuth 2.0 (RFC 8707)
- OAuth 2.0 Authorization Server Issuer Identification (RFC 9207)
- MCP Registry に
jp.calil/libraryとして登録しています
ツールの機能
- 図書館蔵書検索 (
search_books)- 複数の図書館システムを横断検索(最大15館)
- フリーワード、書名、著者、出版者、NDC分類、出版年による検索
- 所蔵館情報と詳細ページURLを提供
- 図書館検索 (
search_libraries)- キーワードによる図書館検索
- システムIDの取得
- NDC分類情報取得 (
get_ndc_info)- 日本十進分類法(NDC第9版)の分類情報を提供
- 上位・下位・関連分類の参照
- 日本図書館協会が公開するオープンデータに基づく
いずれのツールも、検索結果を構造化データ(structuredContent)でも返します。検索条件の誤りはツールのエラー(isError)として返すので、AIが条件を直して検索し直せます。
制限事項
- 複数の自治体が同じ図書館システムを共有している場合、正しく検索できないことがあります
- ユーザー単位と全体で利用回数の制限が設定されています
- カーリル側でのアップデート等により再認証が必要となる場合があります
- 現在、認証機能はレート制限(アクセス回数の制御)のためだけに使用しています
LLM向けのドキュメント
このサイトの内容を、AIが読みやすいテキストでも提供しています。AIアシスタントにカーリル for AIの使い方を尋ねるときなどにご利用ください。
- llms.txt:ページの一覧(llms.txtの形式)
- llms-full.txt:全ページの本文をまとめたもの
- 各ページのMarkdown版:ページのURLの末尾の
/を.mdに替えたもの。トップページと一覧ページはURLにindex.mdを足したもの(例:guides/claude.md)
変更履歴
これまでの技術仕様の変更は、リリースノートでご覧いただけます。